ESXI6.7u3无法识别固态硬盘

liansishen25天前0

新手第一次接触ESXI
安装了6.7U3的版本
系统是安装再U盘上的
主板是x10dri,通过pcie的m.2转接卡插了一块pm981→pm983a
另有一张8125b的pcie网卡,手动安装驱动之后可以识别出来2500M的速率
在存储的适配器选项卡里面可以看到这块硬盘

但是到设备选项卡就只能看到安装系统的U盘了

求指导怎么才能识别到这块硬盘?
是不是需要安装esxi7.0版本?
2022/5/1补充
多谢各位解答
硬盘型号我记错了,不是pm981,而是pm983a,在7.0u2版本的适配器选项卡,型号里会把pm983也显示出来

这两天又折腾了一下
6.5u2、6.7、7.0u2都装过了
仍然不能识别
进PE是可以识别出这块硬盘的
可以用工具对该硬盘格式化、分区等
最新回复 (14)
  • 1.建议更新X10dri支持NVME的BIOS,网上应该有打包好的;
    2.在6.7U2更新时,由于ESXi遵照了NVMe 1.3 规范去识别和支持设备,某些消费级别的NVMe因为不支持该规范而无法被ESXi识别并使用,照理说PM981不会出现这样的情况,可以使用ESXi6.5U2版本试一下或者使用别人打包好的包含社区NVME驱动的ESXI版本。
  • c2h6o25天前
    引用3
    应该是驱动问题,建议降低版本。之前在一个东芝的2230盘上遇到过。
  • jyjs399325天前
    引用4
    我用原版的ESXI6.7U3,配合PM981,还有970EVO,970PRO都可以正常用,楼主的版本是不是有问题?
    试试这个版本VMware-VMvisor-Installer-201912001-15160138.x86_64.ISO的版本
  • liuleisail25天前
    引用5
    驱动问题吧,网上有集成驱动的安装版本。
  • nnmm99925天前
    引用6
    “pcie的m.2转接卡插了一块pm981”,可能ESXI没有识别该转接卡
  • Aesir25天前
    引用7
    nnmm999 发表于 2022-4-30 08:31
    “pcie的m.2转接卡插了一块pm981”,可能ESXI没有识别该转接卡
    转接卡应该没有芯片
  • 楼主liansishen24天前
    引用8
    tian349776608 发表于 2022-4-30 07:58
    1.建议更新X10dri支持NVME的BIOS,网上应该有打包好的;
    2.在6.7U2更新时,由于ESXi遵照了NVMe 1.3 规范去 ...
    1.bios没有找到现成的,准备自己修改一个试试
    2.6.5u2装过了,仍然不行
  • 楼主liansishen24天前
    引用9
    jyjs3993 发表于 2022-4-30 08:17
    我用原版的ESXI6.7U3,配合PM981,还有970EVO,970PRO都可以正常用,楼主的版本是不是有问题?
    试试这个版本 ...
    硬盘型号搞错了,是pm983a
    各个esxi版本都试了,还是不行
  • promind24天前
    引用10
    新建数据存储看不到这块硬盘吗
  • lclancey24天前
    引用11
    pm983a并不支持 别纠结了 无解
    这个东西的ID是跟正常版的PM983一样 但是无法驱动 我看到有说法是三星只给他的采购商(facebook)提供了驱动
    但是你有一种另外的用法 因为设备可识别 所以你可以把它直通给Windows或者Linux虚拟机 让这个系统独占的情况下可以用
  • lclancey24天前
    引用12
    顺便提一下 这玩意按我自己测试和群里报告的结果是:
    Windows支持 无异样
    Linux支持 基于Linux的PVE也支持 基于Linux的TrueNAS Scale支持
    基于FreeBSD的TrueNAS Core需要某些版本支持 旧有的有bug
    黑苹果不支持 启动有几率失败 能启动也只能看到设备不能使用
    ESXi不支持
  • 楼主liansishen23天前
    引用13
    lclancey 发表于 2022-5-1 15:55
    pm983a并不支持 别纠结了 无解
    这个东西的ID是跟正常版的PM983一样 但是无法驱动 我看到有说法是三星只给他 ...
    就打算这么用了直通给里面的虚拟机
    新下单了一块sata固态
  • lee41094386123天前
    引用14
    还好。。我之前买过十几块NVME的。。。就是没PM983。。。
  • imyz23天前
    引用15
    能识别出硬件的,估计是要手工创建 Datastore,可试下 SSH 登录后用以下命令看下磁盘设备:
    ls /vmfs/devices/disks/
    如果有,则找到对应的设备名后,再用以下命令显示下分区情况:
    partedUtil getptbl "/vmfs/devices/disks/<你对应的设备名>
    然后再照以下的官方文档手工创建 Datastore:
    https://kb.vmware.com/s/article/1036609?lang=zh_cn
    注意:此操作涉及到磁盘分区,切记看懂、看清楚再动手!!!
  • 游客
    16
返回