问个 Debian 下编译 git 的问题

boell 29天前 15

原先在 Debian 8 环境下,因为自带的 git 版本太低,用下述方法编译安装了 git 2.20.4:

apt-get install libcurl4-openssl-dev libexpat1-dev gettext libz-dev libssl-dev build-essential autoconf
curl -L --progress https://github.com/git/git/archive/v2.20.4.tar.gz | tar xz && cd git-2.20.4
make configure && ./configure && make prefix=/usr/local all
make prefix=/usr/local install

现在换了 Debian 9,自带的 git 2.11 版本还是低了点,于是用同样的指令去编译,结果碰到一大堆 error,不知如何解决。请大佬们指点一下 Debian 9 该如何安装较新的 git ?
最新回复 (2)
  • lcdtyph 19天前
    引用 2
    去装 backports 的 git 2.20.1 吧
  • 楼主 boell 19天前
    引用 3
    @lcdtyph 谢谢,已搞定。
  • 游客
    4
返回