发觉linux新系统对软件兼容性差了

aaawww 13天前 7

前两天刚买了个腾讯云的香港轻量。在选什么系统时,我犹豫了一会。由于看到消息,说是centos将要被抛弃,而坛子很多大佬又推荐debian。于是我就选了debian 10.2 。然后在装军哥的lnmp一键包时,提示debian 10不支持我选的php5.6版本。这就很尴尬了啊。我的网站程序都是只能支持php5.x的,debian 10如果只能支持php7.1 以上的话,那对我就没什么用了。看来,我还是只能老实用回centos7.x了。另外,我看到现在很多网站源码,都还是只能用到php7.0以下版本,linux系统的更新换代,是不是兼容性太差了?
最新回复 (17)
  • ftp1 13天前
    引用 2
    那你就按照debian9嘛
  • TechBlack 13天前
    引用 3
    和系统无关,和你技术有关。   另外早日php5升级到7性能安全都有提升。
  • Sparta 13天前
    引用 4
    debian 10 可以安装php5.6
    一条命令的事
    1. sudo apt install software-properties-common
    2. wget -q https://packages.sury.org/php/apt.gpg -O- | sudo apt-key add -
    3. echo "deb https://packages.sury.org/php/ stretch main" | sudo tee /etc/apt/sources.list.d/php.list
    4. sudo apt update
    5. sudo apt install php5.6
  • chitycheng 13天前
    引用 5
    linux又不是debian 10
  • 楼主 aaawww 13天前
    引用 6
    ftp1 发表于 2021-2-20 09:02
    那你就按照debian9嘛
    腾讯云后台没有debian9可选了
  • 热心市民 13天前
    引用 7
    aaawww 发表于 2021-2-20 09:06
    腾讯云后台没有debian9可选了
    dd一个不会么
  • 风为裳 13天前
    引用 8
    aaawww 发表于 2021-2-20 09:06
    腾讯云后台没有debian9可选了
    后台没有那就自己装一个不就好了
  • 楼主 aaawww 13天前
    引用 9
    热心市民 发表于 2021-2-20 09:11
    dd一个不会么
    本人小白一个,不会这么复杂的了啊,只能用直接简单的了
  • 楼主 aaawww 13天前
    引用 10
    TechBlack 发表于 2021-2-20 09:02
    和系统无关,和你技术有关。   另外早日php5升级到7性能安全都有提升。
    这个,本人是真小白一个,修改系统源码来适应php7.1对我是不可想像的任务了。。。
  • fox33 13天前
    引用 11
    我喜欢你的头像
  • swsh007 13天前
    引用 12
    dd一个自己喜欢的就是
  • 达雅 13天前
    引用 13
    用centos 8以上版本就好了
  • 楼主 aaawww 13天前
    引用 14
    Sparta 发表于 2021-2-20 09:12
    debian 10 可以安装php5.6
    一条命令的事
    膜拜大神了!我想都想不到还可以有这种操作的。不过,这样系统环境好像要一件件来安装了,不能直接用lnmp一键包了。
  • Sakuya 13天前
    引用 15
    人家发明了 docker,不就是干这个的吗
  • waz 13天前
    引用 16
    debian10 完全可以装php5.6啊。。。只是你用的那个一键包不支持而已
  • 楼主 aaawww 13天前
    引用 17
    waz 发表于 2021-2-20 09:26
    debian10 完全可以装php5.6啊。。。只是你用的那个一键包不支持而已
    大佬知道还有哪个一键包是可以的吗?能否说一下呢,我只知道军哥的lnmp了
  • suichang 13天前
    引用 18
    这也和兼容性扯上关系。。。
  • 游客
    19
返回