EPYC跑仿真速度不理想,原因何在?-CPU

iCola 1月前 21

老板的服务器7742 x2 + 1TB 16通道 3200MHz内存,但是部分场景仿真(Ansys HFSS)速度还远不如我自用的5900X平台(速度大概差3-5倍)。。按理说内存带宽、核心数应该已经很到位了啊。。难道真是优化问题。。有没有大佬支个招
最新回复 (16)
  • スカジ 1月前
    引用 2
    我记得有个tuning guide
    https://developer.amd.com/wp-content/resources/56827-1-0.pdf
  • yulizi 1月前
    引用 3
    是不是跟 matlab 一样要设置 MKL_DEBUG_CPU_TYPE=5
  • gtx9 1月前
    引用 4
    你这是aida64测试不正常啊,虚拟机跑的?
  • chainofhonor 1月前
    引用 5
    试试重装系统,然后只装那个软件其他任何软件都不装
  • HZJ 1月前
    引用 6
    有限元计算软件支持avx512指令集的吧,不过你这都是AMD自己和自己比就奇怪了。
    你试试跑个网格很少的模型,用单核计算看看差多少。
  • HZJ 1月前
    引用 7
    对了,这种东西还是去专业论坛问问看,推荐下simwe论坛,做数值仿真的论坛,里面分类挺细的:
    http://forum.simwe.com/
  • 可以在bios里面切换一下NPS模式再跑一下试试。特别是切成NPS4。
  • gtx9 发表于 2021-3-19 14:25
    你这是aida64测试不正常啊,虚拟机跑的?
    差不多的,损耗挺大的, 2666标准时序双路8x实际就250左右
  • yiyiyao 1月前
    引用 10
    我輩樹である 发表于 2021-3-19 15:51
    可以在bios里面切换一下NPS模式再跑一下试试。特别是切成NPS4。
    有没有人测试过Intel Compiler Patcher优化后的性能?
    https://www.chiphell.com/thread-2000173-1-1.html
    导师你测试过么?
  • yiyiyao 发表于 2021-3-19 16:16
    有没有人测试过Intel Compiler Patcher优化后的性能?
    https://www.chiphell.com/thread-2000173-1-1.html ...
    我只用GPU做运算。
  • yiyiyao 1月前
    引用 12
    我輩樹である 发表于 2021-3-19 16:44
    我只用GPU做运算。
    那我推荐楼主尝试一下,他是用CPU做运算的。
  • 275036739 1月前
    引用 13
    HZJ 发表于 2021-3-19 15:24
    有限元计算软件支持avx512指令集的吧,不过你这都是AMD自己和自己比就奇怪了。
    你试试跑个网格很少的模型, ...
    7742是ZEN2 5900X是ZEN3 难道是这个区别?
  • 275036739 1月前
    引用 14
    HZJ 发表于 2021-3-19 15:24
    有限元计算软件支持avx512指令集的吧,不过你这都是AMD自己和自己比就奇怪了。
    你试试跑个网格很少的模型, ...
    https://www.anandtech.com/show/1 ... -and-5700x-tested/6
    AVX2的好像ZEN3能快几倍。。
  • 楼主 iCola 1月前
    引用 15
    谢谢各位了,另外看到了一些帖子,初步怀疑是license问题(和谐版),出现核心设置越大反而变慢的情况。但是学校被漂亮国ban了,买不了正版,所以无法测试是不是这个原因了
  • tayalife 1月前
    引用 16
    lz壕啊,我也有类似需求,但搞不清楚到底amd的效果如何,于是前年搞了一套3600x来试试水,结果发现跑hfss效能基本和x99的5820k别无二致,同样算例基本上时间没任何差别。后来放弃了yes,搞了x299的14核。以下纯属猜测,一方面可能是ansys对intel的优化更多(同样的核心,更高的频率,3600x对5820k完全体现不出进步),另一方面可能是amd现在用的chiplet结构,5900x是两颗chiplet拼接,而每颗7742内部是8颗chiplet拼接,猜测hfss还没针对这种跨chiplet的并行加速做优化,导致需要参与的chplet越多,chiplet之间数据通信开支反而越大,反而拖累了速度?
  • cain.lin 1月前
    引用 17
    iCola 发表于 2021-3-19 17:03
    谢谢各位了,另外看到了一些帖子,初步怀疑是license问题(和谐版),出现核心设置越大反而变慢的情况。但 ...
    看看l3是不是设置成了numa domain
  • 游客
    18
返回